Google SSO authentication issues
Incident Report for Playvox
Resolved
We received confirmation that affected customers are now able to log in using their Google accounts. Please let us know reaching out to support@playvox.com in case you still have issues.
Posted Apr 21, 2020 - 08:19 PDT
Investigating
We received reports that some customers are not being able to log in using their Google Account. We applied a fix to address the Google authentication changes in their service. Access to Playvox using Playvox credentials was not affected. Please reach us to support@playvox.com if you still have issues.
Posted Apr 21, 2020 - 07:39 PDT
This incident affected: Application/Platform (Application/Platform).