We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 14:52 PDT
Update
We are seeing signs of service recovery, and performance has improved across affected components. However, AWS has not yet issued a final communication confirming full resolution of the underlying issue.
Posted Oct 20, 2025 - 13:06 PDT
Update
We are observing renewed intermittent issues affecting some services. Users may experience occasional errors or degraded performance.
Posted Oct 20, 2025 - 10:00 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 09:01 PDT
Monitoring
The platform is currently stable, and services in the affected region are operating normally. Our team continues to closely monitor performance to ensure full recovery and stability.
We will provide a final update once the incident is confirmed as fully resolved.
Posted Oct 20, 2025 - 07:07 PDT
Investigating
We are currently experiencing a service degradation due to an ongoing AWS outage affecting the us-east-1 region. This may result in increased latency, errors, or partial unavailability for users in this region.
Our engineering team is actively monitoring the situation and coordinating with AWS to mitigate the impact. You can follow the official AWS status updates here: