Pages not loading
Incident Report for Playvox
Resolved
This incident has been resolved. If you're still having issues loading pages please reach us at support@playvox.com.
We're truly sorry for the interruption today. We appreciate your patience and understanding.
Posted Apr 30, 2021 - 10:15 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2021 - 08:55 PDT
Investigating
We have reports of some customers having issues loading certain pages within the platform.

For those customers who are unable to access Playvox (e.g. seeing a blank screen or the page just not loading), try a hard refresh on your browser (CTRL/CMD + R/Ctrl + F5), please reach out to support@playvox.com if you still have issues.

We'll update shortly when we have new updates on this.
Posted Apr 30, 2021 - 07:02 PDT
This incident affected: Application/Platform (Application/Platform).